HDU 4951 Multiplication table 数论

Problem Description
Teacher Mai has a multiplication table in base p.

For example, the following is a multiplication table in base 4:

* 0 1 2 3
0 00 00 00 00
1 00 01 02 03
2 00 02 10 12
3 00 03 12 21


But a naughty kid maps numbers 0..p-1 into another permutation and shuffle the multiplication table.

For example Teacher Mai only can see:

1*1=11 1*3=11 1*2=11 1*0=11
3*1=11 3*3=13 3*2=12 3*0=10
2*1=11 2*3=12 2*2=31 2*0=32
0*1=11 0*3=10 0*2=32 0*0=23


Teacher Mai wants you to recover the multiplication table. Output the permutation number 0..p-1 mapped into.

It's guaranteed the solution is unique.
 

Input
There are multiple test cases, terminated by a line "0".

For each test case, the first line contains one integer p(2<=p<=500).

In following p lines, each line contains 2*p integers. The (2*j+1)-th number x and (2*j+2)-th number y in the i-th line indicates equation i*j=xy in the shuffled multiplication table.

Warning: Large IO!
 

Output
For each case, output one line.

First output "Case #k:", where k is the case number counting from 1. The following are p integers, indicating the permutation number 0..p-1 mapped into.
 

Sample Input
  
  
4 2 3 1 1 3 2 1 0 1 1 1 1 1 1 1 1 3 2 1 1 3 1 1 2 1 0 1 1 1 2 1 3 0
 

Sample Output
  
  
Case #1: 1 3 2 0
 

Source

可以抽象为10进制找到规律,输入输出数据太多,需要用到输入挂,否则会T


#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <set>
#include <vector>
#include <algorithm>
#define maxn 510
using namespace std;

int mark[maxn];
void read(int &a) {
    int t;
    while (t = getchar(), isspace(t));
    a = t - '0';
    while (t = getchar(), !isspace(t)) a = a * 10 + t - '0';
}
int mk[maxn],cnt[maxn],get_zero[maxn];
int main()
{
	//freopen("1007.in","r",stdin);
	//freopen("data.out","w",stdout);
	int n;
	int cas=0;
	while (~scanf("%d",&n))
	{	
		for(int i=0;i<n;i++)
		{
			cnt[i]=0;
		}
		if(n==0) break;
		int tp,tp2;
		
		printf("Case #%d:",++cas);
		for(int i=0;i<n;i++)
		{
			int bl=0;
			memset(mk,-1,sizeof(mk));
			for(int j=0;j<n;j++)
			{
				read(tp);read(tp2);
				//scanf("%d %d",&tp,&tp2);
				if(mk[tp]!=tp){
					cnt[i]++;
					mk[tp]=tp;
				}
				if(mk[tp2]!=tp2)
				{
					bl=1;
				}
			}
			if(!bl&&cnt[i]==1) {
				cnt[i]=0;
			}
			
		}
		for(int i=0;i<n;i++)
		{
	//		printf("%d\n",cnt[i]);
			mark[cnt[i]]=i;
		}
		for(int i=0;i<n;i++)
		{
			printf(" %d",mark[i]);
		}
		puts("");
		
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值