POJ 1703

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.


并查集模板题。

几个帮派就有几个合并函数,然后有几个帮派就有多少乘以n个father元素,相当于为每个罪犯创建两个元素,就是这样的模板。

假设罪犯1,2,设前n为帮派1,后n为帮派2。如果1 2 同一个帮派,那么1-1==2-1,1-2==2-2表示罪犯1属于帮派几罪犯2也属于帮派几;

如果1 2不是同一个帮派,1-1==2-2,1-2==2-1,表示罪犯1是帮派1,那么罪犯2是帮派2,罪犯1是帮派2,那么罪犯2是帮派1,两个人永远不在一个帮派,所以不同帮。

其他情况表明罪犯1 2关系不确定。

PS:这题对于rank数组没必要,删去不影响。


#include <iostream>
#include <set>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn=1e5+5;
int father[maxn*2],Rank[maxn*2];

int Find(int i)
{
    if(father[i]==i) return father[i];
    else return Find(father[i]);
}

void hebing(int i,int j)
{
    i=Find(i);
    j=Find(j);
    if(i==j) return ;
    if(Rank[i]>Rank[j]) father[j]=i;
    else
    {
        if(Rank[i]==Rank[j]) Rank[j]++;
        father[i]=j;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(father,0,sizeof(father));
        int n,m,a,b;
        char ch;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n*2;i++)
            father[i]=i;
        for(int i=1; i<=m; i++)
        {
            getchar();
            scanf("%c%d%d",&ch,&a,&b);
            if(ch=='A')
            {
               int p1=Find(a),q1=Find(b),p2=Find(a+n),q2=Find(b+n);
               if(p1==q1 && p2==q2) cout << "In the same gang.\n";
               else if(p1==q2 && p2==q1) cout << "In different gangs.\n";
               else cout << "Not sure yet.\n";
            }
            else if(ch=='D')
            {
                hebing(a,b+n);
                hebing(a+n,b);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值