习题4-6 水仙花数
水仙花数是指一个N位正整数(N≥3),它的每个位上的数字的N次幂之和等于它本身。例如:153=13+53+33。 本题要求编写程序,计算所有N位水仙花数。
输入格式:
输入在一行中给出一个正整数N(3≤N≤7)。
输出格式:
按递增顺序输出所有N位水仙花数,每个数字占一行。
输入样例:
3
输出样例:
153 370 371 407
代码长度限制
16 KB
时间限制
2500 ms
内存限制
64 MB
代码实现:
#include <stdio.h>
#include <math.h>
int isthenum(int num);
void printfnum(int n);
int main(){
int X;
scanf("%d",&X);
printfnum(X);//输出函数
return 0;
}
int isthenum(int num){//判断是否是水仙花数
int n=num,count=0;
int i,res=1,sum=0;
while(n>0){
n/=10;
count++;
}
n=num;
while(n>0){
res=1;
for(i=1;i<=count;i++){
res*=n%10;
}
sum+=res;
n/=10;
}
if(num==sum){
return 1;
}else{
return 0;
}
}
void printfnum(int n){
int i;
for(i=pow(10,n-1);i<=pow(10,n);i++){
if(isthenum(i)){
printf("%d\n",i);
}
}
return;
}