1016 Phone Bills-PAT甲级

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

解题思路:每一个人的通话记录放在一个map里面,map的值由set集来组合形成,遍历每个人的set集即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
struct Time{//定义时间类
	int month,day,hour,minute,time,online=0;
	//月日时分信息,距0日0时0分的分钟数,指明状态 
	bool operator < (const Time &a)const{
		return time<a.time;
	}
};
double price[25];//存储一天内各个小时段的话费单位是美元/分钟
double compute(Time t,int day){
	//计算当前时间到day日0时0分所用话费
	double bill=0.0;
	for(int i=0;i<t.hour;i++){
		bill+=60*price[i];
	} 
	bill+=(t.minute*price[t.hour]);
	bill+=(price[24]*60*(t.day-day));
	return bill;
} 
int main(){
	for(int i=0;i<24;i++){
		//读取一天内各个小时段的话费
		scanf("%lf",&price[i]);
		price[i]/=100.0;
		price[24]+=price[i]; 
	}
	int n;
	scanf("%d",&n);
	map<string,set<Time>>bill;//存储每个人的名字和对应的话费时间
	for(int i=0;i<n;i++){
		//读取账单
		string s1,s2;
		Time t;
		cin>>s1;
		scanf("%d:%d:%d:%d",&t.month,&t.day,&t.hour,&t.minute);
		t.time=(t.day*24+t.hour)*60+t.minute;
		cin>>s2;
		if(s2=="on-line")
			t.online=1;
		bill[s1].insert(t); 
	} 
	for(auto i=bill.begin();i!=bill.end();i++){
		//查找有效的话费记录并计算用时与话费
		bool output=false;
		//该人的话费记录是否需要输出
		double sumBill=0.0;//该人的话费总额
		for(auto j=(i->second).begin();j!=(i->second).end();j++){
			auto jnext=j;//定义指向j的下一个对象的迭代器
			jnext++;
			if(jnext==(i->second).end()) break;
			if(j->online&&!jnext->online){
				if(!output){
					output=true;
					printf("%s %02d\n",(i->first).c_str(),j->month);
				}
				printf("%02d:%02d:%02d %02d:%02d:%02d ",j->day,j->hour,j->minute,jnext->day,jnext->hour,jnext->minute);
				int tt=jnext->time-j->time;
				double nn=compute(*jnext,j->day)-compute(*j,j->day);
				sumBill+=nn;
				printf("%d $%.2f\n",tt,nn);	
				j++;
				if(j==(i->second).end()) break;
			} 
		}
		if(output){
			printf("Total amount: $%.2f\n",sumBill);
		} 
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值