1021 Deepest Root -PAT甲级

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

用并查集来求连通量,用深度优先搜索来求以每棵树为根结点时树的最大深度即可

满分代码如下;

#include<bits/stdc++.h>
using namespace std;
const int N=10005;
//并查集
int fa[N],level[N],vst[N],maxlevel[N];
void init(){
	for(int i=0;i<N;i++){
		fa[i]=i;
	}
} 
int get(int x){
	if(fa[x]==x)
		return x;
	return fa[x]=get(fa[x]);
}
void merge(int x,int y){
	x=get(x);
	y=get(y);
	if(x!=y){
		fa[x]=y;
	}
}
bool same(int x,int y){
	return get(x)==get(y);
}
vector<int>graph[N];
int n;
void dfs(int a,int start){
	vst[a]=1;
	for(auto i:graph[a]){
		if(!vst[i]){
			vst[i]=1;
			level[i]=level[a]+1;
			maxlevel[start]=max(maxlevel[start],level[i]);
			dfs(i,start);
		}
	}
}
int main(){
	init();
	scanf("%d",&n);
	int a,b;
	for(int i=1;i<n;i++){
		scanf("%d%d",&a,&b);
		graph[a].push_back(b);
		graph[b].push_back(a);
		if(!same(a,b)){
			merge(a,b);
		}
	}
	int cnt=0;
	//计算并查集中集合的数量 
	for(int i=1;i<=n;i++){
		if(fa[i]==i){
			cnt++;
		}
	}
	if(cnt!=1){
		printf("Error: %d components\n",cnt);
		return 0;
	}
	memset(maxlevel,0,sizeof(maxlevel));
	for(int i=1;i<=n;i++){
		memset(level,0,sizeof(level));
		memset(vst,0,sizeof(vst));
		dfs(i,i);
	}
	int maxx=-1;
	vector<int>ve;
	for(int i=1;i<=n;i++){
		if(maxlevel[i]>maxx){
			maxx=maxlevel[i];
			ve.clear();
			ve.push_back(i);
		}else if(maxlevel[i]==maxx){
			ve.push_back(i);
		}
	}
	for(int i=0;i<ve.size();i++){
		printf("%d\n",ve[i]);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值