2018A组6航班时间

 

【问题背景】
小h前往美国参加了蓝桥杯国际赛。小h的女朋友发现小h上午十点出发,上午十二点到达美国,于是感叹到“现在飞机飞得真快,两小时就能到美国了”。

小h对超音速飞行感到十分恐惧。仔细观察后发现飞机的起降时间都是当地时间。由于北京和美国东部有12小时时差,故飞机总共需要14小时的飞行时间。

不久后小h的女朋友去中东交换。小h并不知道中东与北京的时差。但是小h得到了女朋友来回航班的起降时间。小h想知道女朋友的航班飞行时间是多少。

【问题描述】
对于一个可能跨时区的航班,给定来回程的起降时间。假设飞机来回飞行时间相同,求飞机的飞行时间。

【输入格式】
从标准输入读入数据。
一个输入包含多组数据。

输入第一行为一个正整数T,表示输入数据组数。
每组数据包含两行,第一行为去程的 起降 时间,第二行为回程的 起降 时间。
起降时间的格式如下

h1:m1:s1 h2:m2:s2

h1:m1:s1 h3:m3:s3 (+1)

h1:m1:s1 h4:m4:s4 (+2)
表示该航班在当地时间h1时m1分s1秒起飞,

第一种格式表示在当地时间 当日 h2时m2分s2秒降落
第二种格式表示在当地时间 次日 h3时m3分s3秒降落。
第三种格式表示在当地时间 第三天 h4时m4分s4秒降落。

对于此题目中的所有以 h:m:s 形式给出的时间, 保证 ( 0<=h<=23, 0<=m,s<=59 ).

【输出格式】
输出到标准输出。

对于每一组数据输出一行一个时间hh:mm:ss,表示飞行时间为hh小时mm分ss秒。
注意,当时间为一位数时,要补齐前导零。如三小时四分五秒应写为03:04:05。

【样例输入】
3
17:48:19 21:57:24
11:05:18 15:14:23
17:21:07 00:31:46 (+1)
23:02:41 16:13:20 (+1)
10:19:19 20:41:24
22:19:04 16:41:09 (+1)

【样例输出】
04:09:05
12:10:39
14:22:05

【限制与约定】
保证输入时间合法,飞行时间不超过24小时。


资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗  < 1000ms

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib> 
using namespace std;
const int minute=60*60;
const int second=60;
int input1()
{
	int dd,mm,ss,time=0;
	scanf("%d:%d:%d",&dd,&mm,&ss);
	time=(dd*minute+mm*second+ss);
	return time;
}
int input2()
{
	int dd,mm,ss,time=0;
	scanf("%d:%d:%d",&dd,&mm,&ss);
	char ch;
	while((ch=getchar())!='\n')
	{
		int flag=0;
	    //cout<<"ch="<<ch<<endl;
		string s="";
		if(isdigit(ch))
		{
			s+=ch;
			dd+=stoi(s)*24;
			//cout<<"dd="<<dd<<endl;
		}
	}
	time=(dd*minute+mm*second+ss);
	return time;
}
void change(int x)
{
	int d=x/minute;
	x%=minute;
	int m=x/second;
	x%=second;
	int s=x;
	printf("%02d:%02d:%02d\n",d,m,s);
}
int main()
{
	int t;
	cin>>t;
    int start1,end1,start2,end2;
    int ff;
	for(int i=0;i<t;i++)
	{
		start1=input1();
		end1=input2();
		start2=input1();
		end2=input2();
		//cout<<start1<<" "<<end1<<" "<<start2<<" "<<end2<<endl;
		ff=(end1-start1)+(end2-start2);
		ff/=2;
		change(ff);
	}
	return 0;
}
/*
3
17:48:19 21:57:24
11:05:18 15:14:23
17:21:07 00:31:46 (+1)
23:02:41 16:13:20 (+1)
10:19:19 20:41:24
22:19:04 16:41:09 (+1)
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值