1089 Insert or Merge-PAT甲级

 

 

 


 

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

这道题的坑点在:有可能在排序的过程中会出现两次相同的结果,比如下面的这个例子

​10
3 1 2 7 5 8 9 4 6 0
1 2 3 5 7 8 9 4 6 0​

可知;有可能下一次是8进行排序,也有可能是4进行排序;刚开始一遇到匹配就退出,一个样例始终过不了,后来修改了程序,

保存最后一次的匹配值,程序passed

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=110;
int a[N],b[N],res[N],tmp[N];//a[N]为输入的序列,res为输出的中间结果
//b[N]为给出的需要比较的结果 tmp[N]数组用作中间的交换结果 
int n;
bool cha(int a[],int b[],int n){
	int flag2=0;
	for(int i=0;i<n;i++){
		res[i]=a[i];
		sort(res,res+i+1);
		int flag=0;//用来标志是否会产生给出的中间结果 
		for(int j=0;j<n;j++){
			if(j<=i){
				if(res[j]==b[j]) continue;
				else{
					flag=1;
					break;
				}
			}else{
				if(a[j]==b[j]) continue;
				else{
					flag=1;
					break;
				}
			}
		}
		if(!flag){
			flag2=1;
			//cout<<"Insertion Sort"<<endl;
			res[i+1]=a[i+1];
			sort(res,res+i+1+1);
			for(int j=0;j<=i+1;j++){
				//if(j!=0) cout<<" ";
				//cout<<res[j];
				tmp[j]=res[j];
			}
			for(int j=i+2;j<n;j++){
				//cout<<" "<<a[j];
				tmp[j]=a[j];
			}
			//return true;
			flag=0;
		}	
	}
	if(flag2){
		cout<<"Insertion Sort"<<endl;
		for(int i=0;i<n;i++){
			if(i!=0) cout<<" ";
			cout<<tmp[i];
		}
		return true;
	}
	return false;
}
bool gui(int a[],int b[],int n){
	vector<int>ve[n+5];
	for(int i=0;i<n;i++){
		ve[i].push_back(a[i]);
	}
	for(int k=1;k<=n;k*=2){
		for(int i=0;i+k<n;i+=2*k){
			/*int t=ve[i].size();
			for(int j=0;j<ve[i].size();j++){
				tmp[j]=ve[i][j];
			}
			ve[i].clear();
			for(int j=0;j<t;j++){
				ve[i].push_back(tmp[j]);
			}*/
			for(int j=0;j<ve[i+k].size();j++){
				ve[i].push_back(ve[i+k][j]);
			}
			sort(ve[i].begin(),ve[i].end());
		}
		int val=0;
		int flag=0;
		for(int i=0;i<n;i+=2*k){
			for(int j=0;j<ve[i].size();j++){
				if(ve[i][j]==b[val]){
					val++;
					continue;
				}else{
					flag=1;
					break;
				}
				
			}
			if(flag) break;
		}
		if(!flag){
			cout<<"Merge Sort"<<endl;
			k*=2;
			for(int i=0;i+k<n;i+=2*k){
				/*int t=ve[i].size();
				for(int j=0;j<ve[i].size();j++){
					tmp[j]=ve[i][j];
				}
				ve[i].clear();
				for(int j=0;j<t;j++){
					ve[i].push_back(tmp[j]);
				}*/
				for(int j=0;j<ve[i+k].size();j++){
					ve[i].push_back(ve[i+k][j]);
				}
				sort(ve[i].begin(),ve[i].end());
		    }
		    int id=0;
		    for(int i=0;i<n;i+=2*k){
		    	for(int j=0;j<ve[i].size();j++){
		    		if(id) cout<<" "; 
		    		cout<<ve[i][j];
		    		id=1;
				}
			}
			return true;
		}
	}
	return false;
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++) scanf("%d",&a[i]);
	for(int i=0;i<n;i++) scanf("%d",&b[i]);
	if(cha(a,b,n)) return 0;
	if(gui(a,b,n)) return 0;
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值