Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.
After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.
Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes
if the two birds belong to the same tree, or No
if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No
并查集的简单应用,求解最大编号时记录出现的最大编号即可,有几个集合对每个数字遍历即可
满分代码如下:
#include<bits/stdc++.h>
using namespace std;
const int N=10005;
int fa[N];
int a[N];
bool vst[N];
void init(){//初始化父节点
for(int i=1;i<=N;i++)
fa[i]=i;
}
int get(int x){//寻找父节点
if(fa[x]==x)
return x;
return fa[x]=get(fa[x]);
}
void merge(int x,int y){//合并两颗子树
x=get(x);
y=get(y);
if(x!=y)
fa[x]=y;
}
bool same(int x,int y){//是否为同一集合
return get(x)==get(y);
}
int n,k,q,max_num=-1;
int main(){
init();
fill(vst,vst+N,0);
int cnt=0;
cin>>n;
for(int i=1;i<=n;i++){
cin>>k;
for(int j=1;j<=k;j++){
cin>>a[j];
max_num=max(a[j],max_num);
if(j>=1){
merge(a[1],a[j]);
}
}
}
for(int i=1;i<=max_num;i++){
int x=get(i);
if(!vst[x]){
cnt++;
vst[x]=1;
}
}
cout<<cnt<<" "<<max_num<<endl;
cin>>q;
for(int i=1;i<=q;i++){
int x,y;
cin>>x>>y;
if(same(x,y)){
cout<<"Yes"<<endl;
}else{
cout<<"No"<<endl;
}
}
return 0;
}