PAT甲级 1118 Birds in Forest (25)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds.Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No


题目大意

一个人在森林里拍N张照,每张照片中有K只小鸟,并且同一张照片中的小鸟在同一棵树上。所有的小鸟都在照片中出现,小鸟编号为1-(<=10000的某个值),问你最多有几棵不同的树和小鸟的数量。 接下来q个询问,每个询问有两个小鸟,这两个小鸟如果在一棵树上就输出“Yes”,否则输出“No”。

解题思路

并查集的一道水题,没有什么坑点。


#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 10000 + 5;
const int MAXM = 100000 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
int n;
int father[MAXN];

int GetFather(int x){return father[x]==x?x:father[x]=GetFather(father[x]);}
void Init(){
    for(int i=0; i<MAXN; i++) father[i]=i;
}
void Union(int x, int y){
    int X=GetFather(x), Y=GetFather(y);
    if(X!=Y) father[X]=Y;
}
int tree, bird;
void Getdata(){
    Init();
    int m;
    tree=0, bird=0;
    for(int i=0; i<n; i++){
        scanf("%d", &m);
        int a, b;
        scanf("%d", &a);
        bird = f_max(bird, a);
        for(int j=1; j<m; j++){
            scanf("%d", &b);
            bird = f_max(bird, b);
            Union(a, b);
        }
    }
    for(int i=1; i<=bird; i++) if(father[i]==i) tree++;
    printf("%d %d\n", tree, bird);
}

void Solve(){
    int q;
    scanf("%d", &q);
    while(q--){
        int x, y;
        scanf("%d%d", &x, &y);
        if(GetFather(x)!=GetFather(y)) printf("No\n");
        else printf("Yes\n");
    }
}
int main(){
    while(~scanf("%d", &n)){
        Getdata();
        Solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值