1129 Recommendation System-PAT甲级

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

利用set来存储每个结构体,利用set的自动排序功能,利用set存值的唯一性,若检测到某个值已经出现过,则先将其删除,将次数改变后再进行插入

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=50010;
struct Node{
	int val;//自身的值 
	int cnt=0;//自身出现的次数 
	Node(){	}
	Node(int v,int c){
		val=v;
		cnt=c;
	}
	bool operator < (const Node &a)const{
		if(cnt!=a.cnt)
			return cnt>a.cnt;
		return val<a.val;
	}
};
int m[N];//记录每个商品购买的次数 
set<Node>st; 
int n,k;
int main(){
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	cin>>n>>k;
	int first;
	cin>>first;
	st.insert(Node(first,1));
	m[first]++;
	for(int i=2;i<=n;i++){
		int val;
		cin>>val;
		cout<<val<<":";
		int s=0;
		for(auto i=st.begin();i!=st.end()&&s<k;i++){
			cout<<" "<<i->val;
			s++;
		}
		cout<<endl;
		auto it=st.find(Node(val,m[val]));
		if(it!=st.end()){
			//已经在集合中出现过
			st.erase(it); 
		}
		m[val]++;
		st.insert(Node(val,m[val]));
		
	}
	
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值