1138 Postorder Traversal -PAT甲级

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

第一种方法:先序+中序建树,利用后序输出第一个遍历的数

优点:思路简单;缺点:容易造成超时,但测试样例均通过了

第二种方法:依据先序和中序的特点输出后序遍历的第一个数,后序遍历的特点是左子树-右子树-根结点,我们可以在中序中依次查找先序的结点值,如果存在左子树,则在左子树中继续查找,如果存在右子树,则在右子树中继续查找,如果只有根结点,则进行输出

满分代码方法一如下:

#include<bits/stdc++.h>
using namespace std;
const int N=50010;
struct node{
	int data;
	node *lchild=NULL;
	node *rchild=NULL;
};
int pre[N],in[N];
int n,flag=-1;
node *create(int prel,int prer,int inl,int inr){
	if(prel>prer)
		return NULL;
	node *root=new node;
	root->data=pre[prel];
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k]==pre[prel])
			break;
	}
	int numleft=k-inl;
	root->lchild=create(prel+1,prel+numleft,inl,k-1);
	root->rchild=create(prel+numleft+1,prer,k+1,inr);
	return root;
}
void postorder(node *root){
	if(flag!=-1) return;
	if(root==NULL)
		return;
	postorder(root->lchild);
	postorder(root->rchild);
	if(flag==-1)
		flag=root->data;
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&pre[i]);
	}
	for(int i=0;i<n;i++){
		scanf("%d",&in[i]);
	}
	node *root=create(0,n-1,0,n-1);
	postorder(root);
	printf("%d\n",flag);
	return 0;
}

满分代码方法二如下:

#include<bits/stdc++.h>
using namespace std;
const int N=50010;
int pre[N],in[N],n;
void findpost(int root,int inl,int inr){
	if(inl==inr){
		printf("%d\n",pre[root]);
		return;
	}
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k]==pre[root]){
			break;
		}
	}
	int numleft=k-inl;
	if(numleft>0){
		findpost(root+1,inl,k-1);
	}else{
		findpost(root+1,k+1,inr);
	}
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&pre[i]);
	for(int i=0;i<n;i++)
		scanf("%d",&in[i]);
	findpost(0,0,n-1);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值