PAT甲级1138 Postorder Traversal (25 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.
Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

题意:给出一个n表示序列中元素的个数,下面给出两行序列,分别是一棵二叉树的前序遍历序列和中序遍历序列。现在让你输出后序遍历序列的第一个数字。
思路:还是老样子,不建树了,直接递归处理。在一个前序遍历中,第一个节点一定是根节点,这样我们在中序遍历中找到这个节点,那么他的左边就是左子树了,他的右边就是右子树了。现在问题来了,左子树的根节点呢?就是前序遍历找到的节点的下一个节点,而右子树的根节点呢,就是当前前序遍历节点的值加上左子树的值,这样就得到了右子树的根节点。然后递归处理就完了。

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 5050
#define maxnode 1000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;

int n;
int pre_order[MAXN],in_order[MAXN];
bool first;

void post_order(int root,int start,int endd)
{
    if(start>endd)
        return ;
    int i=start;
    while(i<endd&&pre_order[root]!=in_order[i])
        i++;
    post_order(root+1,start,i-1);
    post_order(root+i-start+1,i+1,endd);
    if(first)
       printf("%d\n",pre_order[root]),first=false;
}

int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&pre_order[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&in_order[i]);
    first=true;
    post_order(0,0,n-1);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值