1145 Hashing - Average Search Time-PAT甲级(素数表的建立+哈希表)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

将给出的数字存到哈希表中,如果出现冲突,则采用二次探测法(只采用正向的),如果截至到(x+Msize^2)%Msize都无法找到合适的位置来存放这个数字,输出不能插入;然后,在表中查找相应的数字,同样的方法,如果找到这个数字或者找到对应的位置为空的情况,则说明找到

题目中还涉及到素数的筛选法,利用埃氏筛选法即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=100005,maxn=10005;
int p[N],itable[maxn];
void isprime(){
	memset(p,1,sizeof(p));
	//素数为1
	p[0]=p[1]=0;
	for(int i=2;i*i<=N;i++){
		if(p[i]){
			for(int j=i+i;j<=N;j+=i){
				p[j]=0;
		    }
		}	
	} 
}
int len,n,m;
int main(){
	isprime();
	memset(itable,0,sizeof(itable));
	scanf("%d%d%d",&len,&n,&m);
	while(!p[len]) len++;
	int x;
	for(int i=1;i<=n;i++){
		int flag=0;
		scanf("%d",&x);
		for(int j=0;j<=len;j++){
			int k=(x+j*j)%len;
			if(itable[k]==0){
				itable[k]=x;
				flag=1;
				break;
			}
		}
		if(flag) continue;
		else printf("%d cannot be inserted.\n",x);
	}
	int sum=0;
	for(int i=1;i<=m;i++){
		int flag=0;
		scanf("%d",&x);
		int j;
		for(j=0;j<=len;j++){
			int k=(x+j*j)%len;
			if(itable[k]==x||itable[k]==0){
				flag=1;
				break;
			}
		}
		if(flag) sum+=(j+1);
		else sum+=(len+1);
	}
	double val=sum*1.0/m;
	printf("%.1f\n",val);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值