1004 Counting Leaves-PAT甲级

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

bfs求解每一层的非叶子结点即可

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
struct Node{
	int v;//数据域
	int level;//层数 
	Node(){}
	Node(int vv,int ll){
		v=vv;
		level=ll;
	}
}node[N];
vector<Node>ve[N];
int n,m,level_sum[N],sum_level=0;//每层的非叶子结点 
void bfs(int root){
	queue<int>q;
	q.push(root);
	node[root].level=1;
	sum_level=1;
	while(!q.empty()){
		int u=q.front();
		q.pop();
		if(ve[u].empty()){
			level_sum[node[u].level]++;
		}	
		for(auto i:ve[u]){
			q.push(i.v);
			node[i.v].level=node[u].level+1;
			sum_level=max(sum_level,node[i.v].level);
		}
	}
}
int main(){
	memset(level_sum,0,sizeof(level_sum));
	scanf("%d%d",&n,&m);
	if(n==0)
		return 0;
	int id,k,x;
	for(int i=1;i<=m;i++){
		scanf("%d%d",&id,&k);
		node[id].v=id;
		for(int j=1;j<=k;j++){
			scanf("%d",&x);
			node[x].v=x;
			ve[id].push_back({x,0});
		}
	}
	bfs(1);
	for(int i=1;i<=sum_level;i++){
		if(i!=1) printf(" ");
		printf("%d",level_sum[i]);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值