PAT A 1031 Hello World for U (20分)

1031 Hello World for U (20分)

吐槽

这个条件描述方式是真的好复杂……明明很简单的事愣是让我绕了好一会儿……

逻辑

搞懂输出格式就行。简单点说就是三边尽可能等长,然后不能等长时底边比另两边大就行。

坑点

测点二大概是6个字符?一开始想着“既然n2>=3那么n+2小于9时设定n2=3就好啦!”……然后就测点二报错了……6个字符时应该n2=4的……

题目

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n
​1
​​ characters, then left to right along the bottom line with n
​2
​​ characters, and finally bottom-up along the vertical line with n
​3
​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n
​1
​​ =n
​3
​​ =max { k | k≤n
​2
​​ for all 3≤n
​2
​​ ≤N } with n
​1
​​ +n
​2
​​ +n
​3
​​ −2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor

代码

#include<iostream>

using namespace std;

int main()
{
	int n = 0;
	char c[81];
	for (int i = 0; i < 81; i++)
	{
		cin >> noskipws >> c[i];
		if (c[i] == ' ' || c[i] == '\n')
			break;
		n++;
	}
	int n1, n2;
	n1 = (n + 2) / 3 - 1;
	n2 = n - n1 * 2;

	for (int i = 0; i < n1; i++)
	{
		cout << c[i];
		for (int ii = 0; ii < n2-2; ii++)
		{
			cout << " ";
		}
		cout << c[n - i - 1] << endl;
	}
	for (int i = 0; i < n2; i++)
	{
		cout << c[n1 + i];
	}
	cin >> n;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值