hdu1098

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
题目大意为:对于函数f(x)=5*x^13+13*x^5+k*a*x,输入任意一个数k,是否存在一个数a,对任意x都能使得f(x)能被65整除,如果存在这样一个数a,则输出,如果不存在,输出no。
解题思路:假如存在a满足条件,因为是任意x,就假设x=1,则f(x)为18+ak,则(18+ak)%65==0,就存在数a,a的取值范围就是1到65,由于是求最小的a,所以只要找到一个a,就输出,然后break。
注:其实在读懂题以后,这就是一个数学问题,开始我不知道怎么确定a的范围,在请教数学好的同学以后,由于除数是65,所以a的范围为1到65,如果是66的话就相当于轮了一个周期。在这些英文题中,会经常有这些关键词(黑体斜体),可以把它标记出来。
 
#include<stdio.h>
int main()
{
 int n,a,k;
 while(scanf("%d",&k)!=EOF)
 {
     for(a=1;a<=65;a++)
     {
         if((18+a*k)%65==0)
           {
              printf("%d\n",a);
              break;
           }
     }
     if(a>=66)
        printf("no\n");
 }
  return 0;
}
 

转载于:https://www.cnblogs.com/qiuhua7777/p/8733854.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值