hdu1098(基础)

43 篇文章 0 订阅

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8405    Accepted Submission(s): 5828


Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 

Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 

Sample Input
  
  
11 100 9999
 

Sample Output
  
  
22 no 4
//hdu1098(基础&数学)
//题目大意:已知f(x) = 5*x^13 + 13*x^5 + k*a*x;
//现在给你给你k的值(k<10000),求a的最小整数值使得对于任意x都有f(x)的值都能整除65;
//解题思路:" arbitrary integer x ,65|f(x)"主要是这句对于任意x都能整除65.由于是任意x都成立。所以可以用特殊值带入方程求解. 
//所以当x=1时,可得:f(1)=k*a+18.所以有18+k*a=i*65(i=1、2、3、4......).这样就可以从小到大枚举i,当找到一个
//i使得a=(i*65-18)/k是一个整数时,该值就是满足上述的最小的a值. 
#include<cstdio>
#include<cstring>
int main()
{
	int k,i,j;
	while(scanf("%d",&k)!=EOF)
	{
		int result=-1;
		for(i=1;i<=10000;i++)
		{
			if((i*65-18)%k==0)
			{
				result=(i*65-18)/k;break;
			}
		}
		if(result==-1)
		 printf("no\n");
		else
		 printf("%d\n",result);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值