【Trie】hdu 1251 统计难题

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262140/131070 K (Java/Others)
Total Submission(s): 77525    Accepted Submission(s): 27001


 

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

 

Sample Input
 
banana band bee absolute acm ba b band abc
 

 

Sample Output
 
2 3 1 0
 
 
Trie统计个数模板题
 
 
代码
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e6+5;
int ch[maxn][30],num[maxn],tot;
void insert(char *s)
{
	int now=0;
	int len=strlen(s);
	for(int i=0;i<len;i++)
	{
		int dig=s[i]-'a';
		if(!ch[now][dig]) ch[now][dig]=++tot;
		now=ch[now][dig];
		num[now]++;
	}
}
int find(char *s)
{
	int now=0;
	int len=strlen(s);
	for(int i=0;i<len;i++)
	{
		int dig=s[i]-'a';
		if(!ch[now][dig]) return 0;
		now=ch[now][dig];
	}
	return num[now];
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	char s[15];
	while(gets(s))
	{
		if(s[0]==NULL) break;
		insert(s); 
	}
	while(gets(s))
	{
		printf("%d\n",find(s));
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Trie树词频统计可以通过遍历整个Trie树来获取每个单词现次数,然后可以将这些现次数存储在一个哈希表中。接着,可以使用排序算法(如快速排序、归并排序等)对这些现次数进行排序,以获得单词的频率排名。 以下是一个Python实现的示例代码: ```python class TrieNode: def __init__(self): self.children = {} self.freq = 0 class Trie: def __init__(self): self.root = TrieNode() def insert(self, word): node = self.root for ch in word: if ch not in node.children: node.children[ch] = TrieNode() node = node.children[ch] node.freq += 1 def dfs(self, node, word, freq_dict): if node.freq > 0: if word in freq_dict: freq_dict[word] += node.freq else: freq_dict[word] = node.freq for ch in node.children: self.dfs(node.children[ch], word + ch, freq_dict) def get_freq_dict(self): freq_dict = {} self.dfs(self.root, '', freq_dict) return freq_dict def sort_by_freq(words): trie = Trie() for word in words: trie.insert(word) freq_dict = trie.get_freq_dict() sorted_words = sorted(words, key=lambda x: freq_dict[x], reverse=True) return sorted_words ``` 在这个实现中,首先定义了一个Trie树,其中节点包含一个字典(用于存储子节点)和一个计数器(用于记录单词现次数)。然后,将所有单词插入Trie树中。接着,使用深度优先搜索(DFS)遍历整个Trie树,以获取每个单词现次数,并将其存储在一个字典中。最后,使用Python内置的sorted函数对单词进行排序,排序方式为按照单词现次数从大到小排序。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值