线段树——B - Balanced Lineup

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题目意思就是求区间最大值和最小值的差

因为代码错了点,一直找,终于找到,卧槽

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 500005//4倍数组大小
#define inf 0x3f3f3f3f
int ma[N],a[N],mi[N];
void build(int l,int r,int rt){//建树
    if(l==r) {
        ma[rt]=a[r];
        mi[rt]=a[r];
        return ;
    }
    int mid=(l+r)/2;
    build(l,mid,rt*2);
    build(mid+1,r,rt*2+1);
    ma[rt]=max(ma[2*rt],ma[2*rt+1]);
    mi[rt]=min(mi[2*rt],mi[2*rt+1]);

}
int querymax(int l1,int r1,int l,int r,int rt){//找最大值
    if(l1<=l&&r1>=r) return ma[rt];//注意这里是原区间是所求区间子集
    int mid=(l+r)/2;
    int ret=0;
    if(l1<=mid){//就是这里,开始写的l,下面开始是r
        ret=max(ret,querymax(l1,r1,l,mid,rt*2));//还有这里,mid没写,难受
    }
    if(r1>mid){
        ret=max(ret,querymax(l1,r1,mid+1,r,rt*2+1));
    }
    return ret;
}
int querymin(int l1,int r1,int l,int r,int rt){//最小值
    if(l1<=l&&r1>=r) return mi[rt];
    int mid=(l+r)/2;
    int ret=inf;
    if(l1<=mid){
        ret=min(ret,querymin(l1,r1,l,mid,rt*2));
    }
    if(r1>mid){
        ret=min(ret,querymin(l1,r1,mid+1,r,rt*2+1));
    }
    return ret;
}
int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
    }
    build(1,n,1);
    int x,y;
    for(int i=1;i<=q;i++){
        scanf("%d%d",&x,&y);
        printf("%d\n",querymax(x,y,1,n,1)-querymin(x,y,1,n,1));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值