算法——矩阵快速幂 求第N个斐波那契数

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11123 Accepted: 7913

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


题意:给你一个求解第N个斐波那契数的公式。 让你求出Fn % 10000。




构造单位矩阵,然后就是矩阵快速幂了。


快速幂的思路就是:

设A为矩阵,求A的N次方,N很大,1000000左右吧。。。

先看小一点的,A的9次方

A^9

= A*A*A*A*A*A*A*A*A  【一个一个乘,要乘9次】

= A*(A*A)*(A*A)*(A*A)*(A*A)【保持格式的上下统一,所以加上这句】

 = A*(A^2)^4 【A平方后,再四次方,还要乘上剩下的一个A,要乘6次】

= A*((A^2)^2)^2【A平方后,再平方,再平方,还要乘上剩下的一个A,要乘4次】


也算是一种二分思想的应用吧,1000000次幂,暴力要乘1000000次,快速幂就只要(log2底1000000的对数) 次,大约20次


//
//  main.cpp
//  斐波那契进阶
//
//  Created by 徐家兴 on 2017/10/9.
//  Copyright © 2017年 徐家兴. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 3
#define LL long long
#define MOD 10007

using namespace std;

struct Matrix
{
    LL a[MAXN][MAXN];
    int r, c;//行数 列数
};
Matrix ori, res;//初始矩阵 和 结果矩阵
void init()//初始化矩阵
{
    memset(res.a, 0, sizeof(res.a));
    res.r = 2; res.c = 2;
    for(int i = 1; i <= res.r; i++)//构造单位矩阵
        res.a[i][i] = 1;
    ori.r = 2; ori.c = 2;
    ori.a[1][1] = ori.a[1][2] = ori.a[2][1] = 1;
    ori.a[2][2] = 0;
}
Matrix multi(Matrix x, Matrix y)
{
    Matrix z;
    memset(z.a, 0, sizeof(z.a));
    z.r = x.r, z.c = y.c;//新矩阵行数等于x矩阵的行数 列数等于y矩阵的列数
    for(int i = 1; i <= x.r; i++)//x矩阵的行数
    {
        for(int k = 1; k <= x.c; k++)//矩阵x的列数等于矩阵y的行数 即x.c = y.r
        {
            if(x.a[i][k] == 0) continue;//优化
            for(int j = 1; j<= y.c; j++)//y矩阵的列数
                z.a[i][j] = (z.a[i][j] + (x.a[i][k] * y.a[k][j]) % MOD) % MOD;
        }
    }
    return z;
}
void Matrix_mod(long long n)
{
    while(n)//N次幂
    {
        if(n & 1)
            res = multi(ori, res);
        ori = multi(ori, ori);
        n >>= 1;
    }
    printf("%lld\n", res.a[1][2] % MOD);
}
int main()
{
    long long N;
    while(~scanf("%lld", &N))
    {
        init();//初始化单位矩阵
        Matrix_mod(N);//矩阵快速幂
    }
    return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值