[POJ2083] Fracal

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 

  • A box fractal of degree 1 is simply 
  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
    B(n - 1)
    B(n - 1) B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-
解析
一道比较简单的分形图,n<=7,则边长最大为739,开一个800*800的数组记录当前是“X”还是“ ”,当他处于第n级时,如果需要向n-1级递归,就有五个方向:
左上角,右上角,中间,左下角,右下角。
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int n;
bool maps[1000][1000];
inline void dfs(int m,int bian,int xx,int yy)
{
    if(m==1){
        maps[xx][yy]=1;
        return;
    }
    dfs(m-1,bian/3,xx-bian/3,yy-bian/3); 
    dfs(m-1,bian/3,xx-bian/3,yy+bian/3);
    dfs(m-1,bian/3,xx+bian/3,yy-bian/3);
    dfs(m-1,bian/3,xx+bian/3,yy+bian/3);
    dfs(m-1,bian/3,xx,yy);    
}
int main()
{
    while(1)
    {
        memset(maps,0,sizeof maps);
        scanf("%d",&n);
        if(n==-1)break;
        int bian=1;
        for(int i=1;i<=n-1;i++) bian*=3;
        dfs(n,bian,(bian+1)/2,(bian+1)/2);//分别传入第n级,边长(长 和 高相等),中心位置的横纵坐标 
        for(register int i=1;i<=bian;i++)
        {
            for(register int j=1;j<=bian;j++)
            {
                if(maps[i][j])printf("X");
                 else printf(" "); 
             }
            printf("\n"); 
        } 
        printf("-\n");
    }
} 
 
 

 

 

转载于:https://www.cnblogs.com/719666a/p/10114827.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值