mooc浙大数据结构01-复杂度2 Maximum Subsequence Sum

题目:

Given a sequence of K integers { N1N2, ..., NK }. A continuous subsequence is defined to be { NiNi+1, ..., Nj } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路:

利用在线查找的方式,每次求得新的最大和的同时得到新的最大和的起点和终点。

我的程序:
#include <iostream>  
  
using namespace std;  
  
int main()  
{  
    int num, i, sum, max;
    int left,right,TempLeft,TempRight;
    cin >> num;  
    int a[100000];
    sum = max= 0;;
    left=right=TempRight=TempLeft=0;
    for(i = 0;i < num;i++)  
    {  
        cin >> a[i];  
    }  
    for (i = 0; i < num; i++)  
    {  
        sum += a[i];
        if (sum > max)  
        { max = sum;
          left=TempLeft;
          right=TempRight;
        }   
        if (sum < 0)  
        { sum = 0;
          TempLeft=TempRight=i+1;
          TempRight=i;
        }
          TempRight++;
        //cout << sum << endl;  
    }  
    if(max>0)
      cout<<max<<" "<<a[left]<<" "<<a[right];
    else 
      cout<<"0"<<" "<<a[0]<<" "<<a[num-1];
  return 0;  
}  

运行示例结果:


复查代码也能看出来,缺少对为0时的情况的考虑.

在前面讲max初值设为-1;

if(max>0)
      cout<<max<<" "<<a[left]<<" "<<a[right];
    else if(max==0)
      cout<<"0"<<" "<<a[left]<<" "<<a[right];
    else if(max<0)
      cout<<"0"<<" "<<a[0]<<" "<<a[num-1];
  return 0;  

结尾加入对max==0的思考。

要注意有几个0或者一个0的时候,第一个和最后一个是同样的值,也要输出两次。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值