HDU A + B for you again (KMP)

A + B for you again

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 30   Accepted Submission(s) : 9
Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

 

Output
Print the ultimate string by the book.
 

 

Sample Input
asdf sdfg
asdf ghjk
 

 

Sample Output
asdfg
asdfghjk
 

 

Author
Wang Ye
 

 

Source
2008杭电集训队选拔赛——热身赛
 
 
 
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn=100010;

int next[maxn];
char s1[maxn],s2[maxn];

void getnext(char *t){
    int len=strlen(t);
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1 || t[i]==t[j]){
            i++;j++;
            next[i]=j;
        }else
            j=next[j];
    }
}

int KMP(char *s,char *t){
    int len1=strlen(s),len2=strlen(t);
    int i=0,j=0;
    getnext(t);
    while(i<len1 && j<len2){
        if(j==-1 || s[i]==t[j]){
            i++;j++;
        }else
            j=next[j];
    }
    if(i==len1)
        return j;
    return 0;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%s%s",s1,s2)){
        int x=KMP(s1,s2);
        int y=KMP(s2,s1);
        if(x==y){
            if(strcmp(s1,s2)<0)
                printf("%s%s\n",s1,s2+x);
            else
                printf("%s%s\n",s2,s1+x);
        }else if(x>y)
            printf("%s%s\n",s1,s2+x);
        else
            printf("%s%s\n",s2,s1+y);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jackge/archive/2013/04/19/3031199.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值