Seeding--zoj2100

Seeding

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

主要就是深搜!

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,ds;
char map[8][8];
int move[4][2]={0,1,0,-1,1,0,-1,0};
int visit[8][8],cot,flag;
void dfs(int x,int y)
{
        int next_x,next_y,i;
        if(cot==ds)//如果已经找完了所有的点就跳出
        {
            flag=1;//设置一个开关
            return;
        }
        for(i=0;i<4;i++)
        {
            next_x=x+move[i][0];
            next_y=y+move[i][1];//往四个方向移动
            if(next_x>=0&&next_x<n&&next_y>=0&&next_y<m)//在图的范围内
            {
                if(!visit[next_x][next_y]&&map[next_x][next_y]!='S') //没被访问过,这个点还不能是S
                {
                    cot++;//访问一次就加一次
                    visit[next_x][next_y]=1;//标记为走过
                    dfs(next_x,next_y);//进入下一层
                    visit[next_x][next_y]=0;//取消标记
                    cot--;//跳出一次就减一次
                }
            }
        }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n||m)
    {
        getchar();
        cot=0;
        ds=0;
        flag=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                visit[i][j]=0;
                scanf("%c",&map[i][j]);
                if(map[i][j]=='.')
                ds++;//记录点的个数
            }
            getchar();
        }
        visit[0][0]=1;//访问过就标记为1
        cot++;//先加一次
        dfs(0,0);//从0,0点开始访问
        //printf("%d\n",ds);
        if(flag)
        printf("YES\n");
        else
        printf("NO\n");
    }
return 0;    
}

 

转载于:https://www.cnblogs.com/Eric-keke/p/4702919.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值