zoj 2100 Seeding

这是一篇关于ZOJ在线判题系统中编号为2100的Seeding问题的讨论。题目描述了Tom如何使用播种机在有石头的田地里播种,目标是覆盖所有无石区域,但不能经过已有种子或石头的区域。题目提供了输入输出示例,并提到解决方案可能需要避免深搜DFS的一些陷阱。作者提到自己在理解问题上遇到困难,但在看到他人代码后找到了思路。
摘要由CSDN通过智能技术生成

Seeding


Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

源代码

<span style="font-size:18px;">#include<stdio.h>
#include<string.h>
int n,m,k;
int sum,count,flag;
char map[10][10];

void dfs(int x,int y)
{
	if(x>0&&x<=n&&y>0&&y<=m&&map[x][y]==0)
	{
		sum++;
		map[x][y]=1;
		if(sum==n*m-count)
		{
			flag=1;
			return;
		} 
		dfs(x+1,y);
		dfs(x-1,y);
		dfs(x,y+1);
		dfs(x,y-1);
		sum--;//如果各个分支都不符合,则返回原来的节点 
		map[x][y]=0;
	}
	
	
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&n)
	{
		sum=0;
		flag=0;
		count=0;
		for(int i=1;i<=n;i++)
			{
				getchar();
				for(int j=1;j<=m;j++)
				{
					scanf("%c",&k);
					if(k=='S')
						{
							map[i][j]=1;
							count++;
						}
					else	
						map[i][j]=0;
						
				}
			}
//		for(int i=1;i<=n;i++)
//			for(int j=1;j<=m;j++)	
//				dfs(i,j);
		dfs(1,1);	//注意,不能写成上面那种~因为每次起点都是(1,1) 
		if(flag)
			printf("YES\n");		
		else
			printf("NO\n");
	} 
	return 0;
} </span>


想了好久想不通,看了同学的代码,思路顿时打开了,毕竟小菜鸟~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值