The Cow Lexicon DP

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10659 Accepted: 5116

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

 

dp[i]表示位置i之前匹配的最小距离,从前到后刷新最优解。
对于每个位置i,在字典中求他的匹配,在字符串中匹配到最长位置p,然后dp[p] = min(dp[p],dp[i]+ p - len-i)
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN 606
#define MOD 1000000
#define INF 1000000009
#define eps 0.00000001
using namespace std;
/*

*/
char dict[MAXN][26];
char str[302];
int len[MAXN], dp[MAXN], w, l;
int main()
{
    scanf("%d%d", &w, &l);
    scanf("%s", str);
    for (int i = 0; i < w; i++)
    {
        scanf("%s", dict[i]);
        len[i] = strlen(dict[i]);
    }
    for (int i = 0; i <= l; i++)
        dp[i] = INF;
    dp[0] = 0;
    for (int i = 0; i < l;i++)
    {
        dp[i + 1] = min(dp[i + 1], dp[i] + 1);
        for (int j = 0; j < w; j++)
        {
            if (dict[j][0] == str[i])
            {
                int pos = i, k = 0;
                while (pos < l)
                {
                    if (str[pos++] == dict[j][k])
                        k++;
                    if (k == len[j])
                    {
                        dp[pos] = min(dp[pos], dp[i] + pos - i - len[j]);
                        break;
                    }
                }
            }
        }
    }
    printf("%d\n", dp[l]);
    return 0;
}

这道题和昨天CF的C题有点像哦。

转载于:https://www.cnblogs.com/joeylee97/p/6915310.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值