POJ 3267 The Cow Lexicon 基础DP

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9199 Accepted: 4369

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source


题意:给你一个比较长的字符串和一些相对短的字符串,问你最少去掉多少个字符使得剩下的长字符序列都是由短字符序列组成的;
思路:用dp[i]表示前i个字符最少去掉字符的数量;而且每次比较时应该从后往前,因为每当增加一个字符时,会不会使得 去掉字符的数量变得更小,即可以得出状态转移方程为:dp[i] = min(dp[i],(i-p1)-len+1+dp[p1-1]))(当以第i个字符能由其中某个短字符序列组成时,p1为前i个字符序列从后往前和短字符序列比较时结束的位置下标,len为该短字符序列的长度),反之dp[i] = d[i-1]+1;
代码:
#include<cstdio>  
#include<cstring>
#include <algorithm>
#include <cmath>
using namespace std;  
#define maxn 100007
#define inf 0x3f3f3f3f
typedef long long LL;
char s1[333],s2[666][30];
int dp[333];
int main()  
{  
#ifdef CDZSC_June
	freopen("t.txt", "r", stdin);  
#endif  
	int n,m,p,min1,p1;
	while(~scanf("%d%d",&n,&m))
	{
		scanf("%s",s1+1);
		for(int i = 0; i<n; i++)
		{
			scanf("%s",s2[i]);
		}
		dp[0] = 0;
		for(int i =1; i<=m; i++)
		{
			min1 = inf;
			for(int j =0; j<n; j++)
			{
				int len = strlen(s2[j]);
				p = len-1;
				if(len <= i){
					for(int k = i;k>=1;k--){
						if(s1[k] == s2[j][p]){
							p--;
							if(p == -1){
								p1 = k;
								break;
							}
						}
					}
				}
				if(p == -1){
					min1 = min(min1,(i-p1)-len+1+dp[p1-1]);
				}
			}
			dp[i] = min(dp[i-1]+1,min1);
		}
		printf("%d\n",dp[m]);
	}
	return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值