HDU 1720 A+B Coming

A+B Coming

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5856    Accepted Submission(s): 3839


Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 

Output
Output A+B in decimal number in one line.
 

Sample Input
 
   
1 9 A B a b
 

Sample Output
 
   
10 21 21
 

Author
威士忌
 

Source





解题思路:水题一枚。就是十六进制的A+B,仅仅要把算得的结果用十进制输出就可以。

只是还是非常恶心的wa了几次。。





AC代码:

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
using namespace std;

int main(){
//	freopen("in.txt", "r",stdin);
	string a, b;
	int x, y;
	while(cin>>a>>b){
		int len = a.size();
		int cnt1 = 0;
		int k = 0;
		while(len){
			char x = a[len-1];
			if(x>='0' && x<='9')  cnt1 += (x - '0')*pow(16, k);
			else if(x>='a' && x<='f')  cnt1 += (x - 'a' + 10)*pow(16, k);
			else  cnt1 += (x - 'A' + 10)*pow(16, k);
			len --;
			k ++;
		}
		len = b.size();
		int cnt2 = 0;
		k = 0;
		while(len){
			char x = b[len-1];
			if(x>='0' && x<='9')  cnt2 += (x - '0')*pow(16, k);
			else if(x>='a' && x<='f')  cnt2 += (x - 'a' + 10)*pow(16, k);
			else  cnt2 += (x - 'A' + 10)*pow(16, k);
			len --;
			k ++;
		}
		
		cout<<(cnt1 + cnt2)<<endl;
	}
	return 0;
}






转载于:https://www.cnblogs.com/mfmdaoyou/p/6955202.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值