The King’s Ups and Downs
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 442 Accepted Submission(s): 298
Problem Description
The king has guards of all different heights. Rather than line them up in increasing or decreasing height order, he wants to line them up so each guard is either shorter than the guards next to him or taller than the guards next to him (so the heights go up and down along the line). For example, seven guards of heights 160, 162, 164, 166, 168, 170 and 172 cm. could be arranged as:
or perhaps:
The king wants to know how many guards he needs so he can have a different up and down order at each changing of the guard for rest of his reign. To be able to do this, he needs to know for a given number of guards, n, how many different up and down orders there are:
For example, if there are four guards: 1, 2, 3,4 can be arrange as:
1324, 2143, 3142, 2314, 3412, 4231, 4132, 2413, 3241, 1423
For this problem, you will write a program that takes as input a positive integer n, the number of guards and returns the number of up and down orders for n guards of differing heights.
or perhaps:
The king wants to know how many guards he needs so he can have a different up and down order at each changing of the guard for rest of his reign. To be able to do this, he needs to know for a given number of guards, n, how many different up and down orders there are:
For example, if there are four guards: 1, 2, 3,4 can be arrange as:
1324, 2143, 3142, 2314, 3412, 4231, 4132, 2413, 3241, 1423
For this problem, you will write a program that takes as input a positive integer n, the number of guards and returns the number of up and down orders for n guards of differing heights.
Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set consists of single line of input containing two integers. The first integer, D is the data set number. The second integer, n (1 <= n <= 20), is the number of guards of differing heights.
Output
For each data set there is one line of output. It contains the data set number (D) followed by a single space, followed by the number of up and down orders for the n guards.
Sample Input
4 1 1 2 3 3 4 4 20
Sample Output
1 1 2 4 3 10 4 740742376475050
Source
大体题意:
给你n个士兵,问n个士兵波浪线排列的方法数 (大小间隔!)
思路:
比赛没有做出来~~(暴力16就卡住了~)
我们要排第i个人,假设前面的方法数是m个,后面的个数是n个 那么就是m*n个,
因此dp[i][0],表示前面的方法数,dp[i-j-1][1]表示后面的个数!
乘起来后,又因为标号是不知道的,还要乘以C[i-1][j]表示从i-1个人选j个!
乘起来即可!
总数肯定是 其中一个dp[i][0]乘以2的,所以 dp[i][0] = dp[i][1] = sum / 2;
最后输出dp[n][0]就好了!
注意 n等于1的特殊情况!
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<string>
#include<iostream>
using namespace std;
typedef unsigned long long llu;
const int maxn = 10000000 + 10;
llu dp[25][2];
int c[25][25];
int main(){
for (int i = 1; i <= 20; ++i){
c[i][0] = c[i][i] = 1;
for (int j = 1; j < i; ++j)
c[i][j] = c[i-1][j-1]+c[i-1][j];
}
//printf("%d\n",c[4][2]);
dp[1][0] = dp[1][1] = dp[0][0] = dp[0][1] = 1;
for (int i = 2;i <= 20; ++i){
llu sum = 0;
for (int j = 0; j < i; ++j){
sum += dp[j][0] * dp[i-j-1][1] * c[i-1][j];
}
dp[i][0] = dp[i][1] = sum/2;
}
int T,cnt;
scanf("%d",&T);
while(T--){
int n;
scanf("%d%d",&cnt,&n);
if(n == 1){
printf("%d 1\n",cnt);
continue;
}
printf("%d %I64u\n",cnt,2*dp[n][0]);
}
return 0;
}