The King’s Ups and Downs hdu 4489 (递推dp)

The King’s Ups and Downs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 562    Accepted Submission(s): 394


Problem Description
The king has guards of all different heights. Rather than line them up in increasing or decreasing height order, he wants to line them up so each guard is either shorter than the guards next to him or taller than the guards next to him (so the heights go up and down along the line). For example, seven guards of heights 160, 162, 164, 166, 168, 170 and 172 cm. could be arranged as:


or perhaps:


The king wants to know how many guards he needs so he can have a different up and down order at each changing of the guard for rest of his reign. To be able to do this, he needs to know for a given number of guards, n, how many different up and down orders there are:

For example, if there are four guards: 1, 2, 3,4 can be arrange as:

1324, 2143, 3142, 2314, 3412, 4231, 4132, 2413, 3241, 1423

For this problem, you will write a program that takes as input a positive integer n, the number of guards and returns the number of up and down orders for n guards of differing heights.
 

Input
The first line of input contains a single integer P, (1 <= P <= 1000), which is the number of data sets that follow. Each data set consists of single line of input containing two integers. The first integer, D is the data set number. The second integer, n (1 <= n <= 20), is the number of guards of differing heights.
 

Output
For each data set there is one line of output. It contains the data set number (D) followed by a single space, followed by the number of up and down orders for the n guards.
 

Sample Input
  
  
4 1 1 2 3 3 4 4 20
 

Sample Output
  
  
1 1 2 4 3 10 4 740742376475050
 

Source
我们考虑。前面已经有i-1个人现在要放第i个人的情况。由于i是最后放的所以他一定是最高的。无论他在哪个位置一定都是波峰。
所以在他前面的部分结尾一定为高低。在他后面的部分开始一定为低高。这样才能形成高低低高。如果知道前面结尾高低的方法数n和后面开始低高的方法数m。那么在该位置的方法数就为n*m。而前面的个数和后面的个数是不确定的所以要枚举前面的个数j。而后面的个数就为i-j-1。由于状态转移要用到结尾高低的方法数和后面开始低高的方法数
所以我们用dp[i][0]表示有i个人且i个人结尾为高低的方法数。dp[i][1]表示有i个人且开始为低高的方法数。
那么有i个人排列的方法数就为ans[i]+=dp[j][0]*dp[i-j-1][1]*c[i-1][j]。c[i-1][j]为方法数。因为不确定前面j个人的标号。所以要在i-1个人中选j个人出来。开始一直纠结标号问题把自己都搞晕了。其实用第i个人把人分到两边。只这样只跟人数有关系系了。
但怎么更新状态转移需要用到的dp[i][1]和dp[i][0]呢?
把i个士兵排好后无非两种情况。开始为低高。开始为高低。那么排列的逆序也满足条件。也就是说 结尾为高低的方法数 开始为低高的方法数 相同。而对于人数一定的情况。开始为低高的人数和开始为高低的人数相等。
证明:我们用0表示波谷1表示波峰。
当n为偶数时.假设波峰开始的序列为1010.那么把它倒置一下就变成了0101了。也就是说每一个1打头的对应着一个0打头的。
当n为奇数时。假设波峰开始的序列为10101.假设第一个数大于最后一个数。那我们把序列最后一个放到第一个位置由于第一个数大于最后一个数所以序列就变成01010.如果第一个数小于最后一个数把第一个数放到最后就行了。所以
每一个1打头的对应着一个0打头的。
所以dp[i][0]=dp[i][1]=ans[i]/2。这样就好递推了。
#include <stdio.h>
#include <math.h>
int c[21][21];
long long ans[21];
long long dp[21][2];
void cal()
{
    for( int i = 1; i <= 20; i++)
    {
        c[i][0] = c[i][i] = 1;
        for(int j = 1; j < i; j++)
        {
            c[i][j] = c[i-1][j] + c[i-1][j-1];
        }
    }
}
void slove()
{
    dp[0][0] = dp[0][1] = dp[1][0] = dp[1][1] = 1;
    for(int i = 2; i <= 20; i++)
    {
        ans[i] = 0;
        for(int j = 0; j < i; j++)
        {
            ans[i] += (dp[j][0] * dp[i-j-1][1])*c[i-1][j];
        }
        dp[i][0] = dp[i][1] = ans[i]/2;
    }
}
int main()
{
    int n;
    scanf("%d", &n);
    cal();
    slove();
    for(int i = 1; i <= n; i++)
    {
        int cas, p;
        scanf("%d%d",&cas,&p);
        if( p == 1)
        {
            printf("%d 1\n",cas);
        }
        else
        printf("%d %lld\n",cas,ans[p]);
    }
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值