HDU 1003 Max Sum (入门DP[1] 最大连续子序列)

101 篇文章 1 订阅

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210999    Accepted Submission(s): 49522


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author

大体题意:
给你一个整数数组,求的一个连续子序列,使得连续子序列和最大,并且输出子序列的和  和起始位置和终止位置!
思路:

据教练指导,入门DP 的第一题!
设计:
dp[i]   表示1.2.3....i  中最大值。
那么转移方程:
  当dp[i-1] < 0时,那么dp[i]最优解肯定是a[i]了,
否则 就是dp[i-1] + a[i]:
然后遍历一遍求得最大值 并且找到最右端位置,然后在从最右端向左找  找到最左端
注意:
找最左端时,不要发现一个最左端就break  要等他找完,因为可能不是最长!
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100000 + 10;
int dp[maxn],a[maxn];
int main(){
    int T,cnt = 0;
    scanf("%d",&T);
    while(T--){
        memset(dp,0,sizeof dp);
        int n;
        scanf("%d",&n);
        for (int i = 1; i <= n; ++i)scanf("%d",&a[i]);
        dp[1]=a[1];
        for (int i = 2; i <= n; ++i){
            if (dp[i-1] < 0)dp[i] = a[i];
            else dp[i] = dp[i-1] + a[i];
        }
        int tmp_max = dp[1],r = 1;// r 一定要初始化为1,可能全是负数!!
        for (int i = 2; i <= n; ++i){
            if (dp[i] > tmp_max){
                tmp_max = dp[i];
                r = i;
            }
        }
        int t = 0,l;
        for (int i = r; i >= 1; --i){
            t += a[i];
            if (t == tmp_max)l = i;
        }
        if (cnt++)printf("\n");
        printf("Case %d:\n",cnt);
        printf("%d %d %d\n",tmp_max,l,r);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值