HDU 1313 Round and Round We Go (Java大数)

7 篇文章 0 订阅

Round and Round We Go

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 907    Accepted Submission(s): 464


Problem Description
A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a ~{!0~}cycle~{!1~} of the digits of the original number. That is, if you consider the number after the last digit to ~{!0~}wrap around~{!1~} back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.

For example, the number 142857 is cyclic, as illustrated by the following table:

142857*1=142857

142857*2=285714

142857*3=428571

142857*4=571428

142857*5=714285

142857*6=857142

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, ~{!0~}01~{!1~} is a two-digit number, distinct from ~{!0~}1~{!1~} which is a one-digit number.)

 

Output
For each input integer, write a line in the output indicating whether or not it is cyclic.
 

Sample Input
  
  
142857 142856 142858 01 0588235294117647
 

Sample Output
  
  
142857 is cyclic 142856 is not cyclic 142858 is not cyclic 01 is not cyclic 0588235294117647 is cyclic
 

Source
 

Recommend

刚刚学习了Java 在做几个大数题目.。
大体题意:
给你一个大数,记len = 大数的位数,那么让大数乘以 1,2,3,4,,,,,len,得到的每一个大数如果都满足首尾相连存在最初的大数的话,那么就是符合要求的大数。
判断每一个大数是否符合要求。

思路:
因为这个题目大数可能会有前导0,所以,用字符串读取大数,
然后 枚举2,3,4,,,,len,构造完这个大数后相乘,然后长度与之前的对比,少的话加前导0,。
最后给当前的大数字符串在重复加一遍,直接利用String里的indexOf 函数,查找某一个子字符串,
找不到就不是,找的到就是了!
import java.util.Scanner;
import java.math.BigInteger;

public class Main{
	public static void main(String[] args){
		Scanner sc = new Scanner(System.in);
		BigInteger a,b,c;
		while(sc.hasNext()){
			String bbs = sc.next();
			int len = bbs.length();
			a = new BigInteger(bbs);
			boolean ok = true;
			for (int i = 2; i <= len; ++i){
				b = BigInteger.valueOf(i);
				c = a.multiply(b);
				String ans = c.toString();
				while(ans.length() < len)ans = "0" + ans;
				ans = ans + ans;
				if (ans.indexOf(bbs) == -1){ok=false;break;}
			}
			System.out.print(bbs);
			if (ok)System.out.println(" is cyclic");
			else System.out.println(" is not cyclic");
		}
		
	}
	
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值