poj1047 Round and Round We Go

Round and Round We Go
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12064 Accepted: 5630

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 
142857 *1 = 142857 
142857 *2 = 285714 
142857 *3 = 428571 
142857 *4 = 571428 
142857 *5 = 714285 
142857 *6 = 857142 

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

题意:给出一个字符串,如果这个字符串分别用1,2,...,len去乘,最终得到的结果还是由这个字符串的字符组成的,那么它是cyclic;

解题思路:给出的数*(len+1)=9...9(len个),那么这个数是cyclic

参考代码:

#include <iostream>
#include <string.h>
using namespace std;
char s[100];
int a[100];
int main(){
	while (cin>>s){
		int len=strlen(s);
		memset(a,0,sizeof(a));
		int k=0,left=0;
		for (int i=len-1;i>=0;i--){
			int ans=(s[i]-'0')*(len+1)+left;
			a[k++]=ans%10;
			left=ans/10;
		}
		while (left!=0){
			a[k++]=left%10;
			left/=10;
		}
		int flag=0;
		for (int i=0;i<k;i++){
			if (a[i]!=9){
				flag=1;
				break;
			}
		}
		if (flag==1)
			cout<<s<<" is not cyclic"<<endl;
		else
			cout<<s<<" is cyclic"<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值