1094: Round And Round We Go

 1094: Round And Round We Go


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K620292Standard
A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a “cycle” of the digits of the original number. That is, if you consider the number after the last digit to “wrap around” back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.

For example, the number 142857 is cyclic, as illustrated by the following table:

 

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, “01” is a two-digit number, distinct from “1” which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.

 

Sample Input

142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

 


This problem is used for contest: 35 

 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=1000;
int main()
{
    string str;
    int a[maxn+1];
    while(cin>>str)
    {
        memset(a,0,sizeof(a));
        int len=str.size();
        int l=maxn;
        for(int i=len-1;i>=0;i--)    a[l--]=str[i]-'0';
        for(int i=maxn;i>=0;i--) a[i]*=len+1;
        for(int i=maxn;i>=0;i--)
        {
            if(a[i]>=10)
            {
                a[i-1]+=a[i]/10;
                a[i]%=10;
            }
        }
        int flag=1,k;
        for(k=0;k<=maxn;k++) if(a[k]) break;
        //for(int i=k;i<=maxn;i++) cout<<a[i];cout<<".."<<endl;
        for(int i=k;i<=maxn;i++) if(a[i]!=9) {flag=0;break;}
        if(flag) cout<<str<<" is cyclic"<<endl;
        else cout<<str<<" is not cyclic"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值