HDU 5437 Alisha’s Party (优先队列模拟)

18 篇文章 0 订阅

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4880    Accepted Submission(s): 1228


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15 .

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000 . The door would open m times before all Alisha’s friends arrive where 0mk . Alisha will have q queries where 1q100 .

The ith of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1vi108 , separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi .

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose
 


Source

大体题意:
有一个朋友聚会,但城堡很小,会开放m次,每次让p个人进入,如果到了的朋友数量小于p个人,就是全部进入,每个朋友都有一个礼物权值,权值大的优先进入,相等的话  先到的先进入,告诉你q个询问,求出第n 个进入的人的名字?
思路:
朋友不是一下子全来,而是一个一个来,并且来的要有排序,所有很容易想到用优先队列来模拟这个过程,
朋友用结构体记录,有名字,id ,权值。

坑:  门会开放m 次,每次在一定数量的人到的时候开,这个人数可能有大有小,需要排个序。
详细见代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<stack>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>

#define fout freopen("out.txt","w","stdout");
using namespace std;
const int maxn = 150000 + 10;
const int inf = 0x3f3f3f3f;
const double eps = 1e-8;
const double pi = acos(-1.0);
const int mod = 1e9+7;
typedef long long ll;
typedef unsigned long long llu;

int gcd(int a,int b){ return !b?a:gcd(b,a%b); }
ll my_pow(ll a,ll n){
    ll ans = 1;
    while(n){
        if (n & 1)
            ans = (ans % mod * a % mod) % mod;
        n/=2;
        a = (a%mod*a%mod)%mod;
    }
    return ans;
}

struct Node{
    char name[250];
    int v;
    int id;
    bool operator < (const Node & rhs)const {
        return v < rhs.v || (v == rhs.v && id > rhs.id);
    }
}p[maxn];
int ans[maxn];
//int cmdf[maxn],cmds[maxn];
struct Node2{
    int f,s;
    bool operator < (const Node2 & rhs) const {
        return f < rhs.f || (f == rhs.f && s < rhs.s);
    }
}cmd[maxn];
int que[105];
priority_queue<Node>pq;
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        while(!pq.empty())pq.pop();
        int cnt = 0;
        int k,m,q;
        scanf("%d %d %d",&k,&m,&q);
        for (int i = 1; i <= k; ++i){
            scanf("%s",p[i].name);
            scanf("%d",&p[i].v);
            p[i].id = i;
        }
        for (int i = 1; i <= m; ++i){
            scanf("%d %d",&cmd[i].f,&cmd[i].s);
        }
        sort(cmd+1,cmd+m+1);
        int cur_come = 0;
        int cur_cmd = 1;
        for (int i = 1; i <= k; ++i){
            cur_come++;
            pq.push(p[i]);
            if (cur_come < cmd[cur_cmd].f)continue;
           // while(cur_come >= cmdf[cur_cmd] && cur_come <= m){
           TT:
               if (cur_cmd > m)continue;
                for (int j = 0; j < cmd[cur_cmd].s; ++j){
                    if (pq.empty())break;
                    Node u = pq.top();pq.pop();
//                    strcpy(ans[++cnt],u.name);
                    ans[++cnt] = u.id;
                }
            //}
            ++cur_cmd;
            if (cmd[cur_cmd].f <= cur_come)goto TT;
        }
        while(!pq.empty()){
            ans[++cnt] = pq.top().id;
            pq.pop();
        }
        for (int i = 0; i <q; ++i){
            scanf("%d",&que[i]);

        }
        for (int i = 0; i < q; ++i){
            int x = que[i];
            if (i)printf(" ");
            printf("%s",p[ans[x]].name);
        }
        puts("");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值