hdu-5437 Alisha’s Party(优先队列)

MarkdownPad Document

Alisha’s Party

9/15/2015 10:20:23 PM

url:http://http://acm.hdu.edu.cn/showproblem.php?pid=5437

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 2276 Accepted Submission(s): 613

Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n?th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i?th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i?th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t?th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1?th,...,nq?th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3

Sample Output

Sorey Lailah Rose

Source

2015 ACM/ICPC Asia Regional Changchun Online


题意:

有很多小伙伴来参加聚会,但是主人只会开有限次的门,每次让限定几个人进来,带的礼物的value值高的优先,然后是先到的优先,每次询问第几个进来的人是谁

解题思路:

采用优先队列,每次来的小伙伴进队列,按礼物的value和到达的顺序排序,每一次开门则让限定的前几个人进入房子,也就是出队列,几下每个人是第几个进入的


  
  
   
   de>#include <iostream>
#include <cstdio>
#include <cstring>
#include <ctime>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
using namespace std;
struct Node
{
    char name[205];
    int value;
    int time;
    friend bool operator< (Node n1, Node n2)
    {
        if(n1.value==n2.value) return n1.time>n2.time;
        return n1.value<n2.value;
    }

};
Node node[150005];
Node ans[150005];
priority_queue<Node>q;
struct Open
{
    int t,n;
}o[150005];
bool cmp(Open a,Open b)
{
    if(a.t<b.t) return true;
    else return false;
}
int main()
{
    int T,k,m;
    Node temp;
    int t,n,w;
    int sum;
    int i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&k,&m,&w);
        while(!q.empty()) q.pop();
        for(i=1;i<=k;i++)
        {
            scanf(" %s%d",node[i].name,&node[i].value);
            node[i].time=i;
        }

        for(i=0;i<m;i++)
        {
            scanf("%d%d",&o[i].t,&o[i].n);
        }
        sort(o,o+m,cmp);
//        for(i=0;i<m;i++)
//            printf("%d %d\n",o[i].t,o[i].n);
        sum=1;
        int g=1;
        for(i=0;i<m;i++)
        {
            for(j=g;j<=o[i].t;j++)
                q.push(node[j]);
            g=o[i].t+1;
            for(j=0;j<o[i].n;j++)
            {
                if(q.empty()) break;
                temp=q.top();
                ans[sum++]=temp;
                q.pop();
            }
        }
        for(j=g;j<=k;j++)
            q.push(node[j]);
        while(!q.empty())
        {
            temp=q.top();
            ans[sum++]=temp;
            q.pop();
        }

//        for(i=1;i<=sum;i++)
//            printf("%s\n",ans[i].name);

        for(i=0;i<w-1;i++)
        {
            scanf("%d",&n);
            printf("%s ",ans[n].name);
        }
       scanf("%d",&n);
            printf("%s\n",ans[n].name);
    }
    return 0;
}

   
   de>
  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值