HDOJ 5437 Alisha’s Party (优先队列)(长春网络赛)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1104    Accepted Submission(s): 306


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15 .

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000 . The door would open m times before all Alisha’s friends arrive where 0mk . Alisha will have q queries where 1q100 .

The ith of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1vi108 , separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi .

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose 大意:一群人去参加party,拿的有不同的礼物,规定例如在第i个人到来时让过去j个人, (礼物贵重的先进,如果相同,就谁先来谁先进),问第k个进去的是谁,注意最后都要进去, 解法:优先队列,不过中间繁琐,刚开始做想到了最后一点但是没写(⊙﹏⊙) ac代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
#define MAXN 150000
using namespace std;
struct s
{
	int a;
	int b;
}come[MAXN];
struct ss
{
	int cas;
	int value;
	friend bool operator<(ss a,ss b)
	{
		if(a.value==b.value)
		return a.cas>b.cas;
		return a.value<b.value;
	}
}d,e;
int val[MAXN+10];
char man[MAXN+10][210];
int num[MAXN+10];
int qq[MAXN+10];
bool cmp(s aa,s bb)
{
	return aa.a<bb.a;
}
int main()
{
	int t;
	int i,j,k,m,pro,qqq;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&k,&m,&qqq);
		priority_queue<ss>q;
		for(i=1;i<=k;i++)
		{
			scanf("%s%d",man[i],&val[i]);
			qq[i]=i;
		}
		for(i=1;i<=m;i++)
		scanf("%d%d",&come[i].a,&come[i].b);
		sort(come+1,come+m+1,cmp);//对要求排序,刚开始以为题目不会要求这个,但是后来一想,还是写吧
		int j=1;
		int ans=1;
		for(i=1;i<=m;i++)
		{
			while(j<=come[i].a&&j<=k)
			{
				d.cas=qq[j];
				d.value=val[j];
				q.push(d);
				j++;
			}
			int w=0;
			while(w<come[i].b&&!q.empty())
			{
				e=q.top();
				num[ans++]=e.cas;
				q.pop();
				w++;
			}
		}
		for(i=j;i<=k;i++)
		{
			d.cas=qq[i];
			d.value=val[i];
			q.push(d);
		}
		while(!q.empty())
		{
		    e=q.top();
			num[ans++]=e.cas;
			q.pop();
		}
		for(i=0;i<qqq;i++)
		{
			scanf("%d",&pro);
			printf(i==qqq-1?"%s\n":"%s ",man[num[pro]]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值