POJ3669 Meteor Shower

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

简直不忍回忆:第一次WA发现一些细节错误;第二次WA发现题目都没看清( a new, safer location 这意味着只要strike的地方就一定不能再走了);第三次TLE,多亏discuss里前辈们的指示,改了下输入方式;第四次又WA把范围从300改到400。到这里才终于AC了哭

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

int n,point[50005][3];
int time[405][405];
vector <int> strike[405][405];
bool visited[405][405];
int dx[4]={-1,0,1,0},dy[4]={0,-1,0,1};
typedef pair<int,int> P;

int bfs();
bool is_strike(int x,int y,int t);
int main()
{
    cin>>n;
    memset(visited,0,sizeof(visited));
    for(int i=0;i<n;i++){
        scanf("%d%d%d",&point[i][0],&point[i][1],&point[i][2]);
        //cin>>point[i][0]>>point[i][1]>>point[i][2];
        int tx=point[i][0],ty=point[i][1];
        (strike[tx][ty]).push_back(point[i][2]);
        for(int j=0;j<4;j++){
            tx=point[i][0]+dx[j];ty=point[i][1]+dy[j];
            if(tx>=0&&tx<=400&&ty>=0&&ty<=400) (strike[tx][ty]).push_back(point[i][2]);
        }
    }
    //debug
    /*for(int i=0;i<5;i++){
            for(int j=0;j<5;j++){
                if(!(strike[i][j]).empty()) cout<<strike[i][j][0]<<" ";
            }
            cout<<endl;
    }*/
    cout<<bfs()<<endl;
    return 0;
}
int bfs(){
    queue<P> q;
    q.push(P(0,0));
    time[0][0]=0;
    visited[0][0]=1;
    while(q.size()){
        P p=q.front();
        //debug
        //cout<<time[p.first][p.second]<<":"<<p.first<<","<<p.second<<endl;
        if((strike[p.first][p.second]).empty()) return time[p.first][p.second];
        q.pop();
        for(int j=0;j<4;j++){
            int tx=p.first+dx[j],ty=p.second+dy[j];
            if(tx>=0&&tx<=400&&ty>=0&&ty<=400) {
                int t=time[p.first][p.second]+1;
                if(!visited[tx][ty]&&!is_strike(tx,ty,t)){
                    visited[tx][ty]=1;
                    time[tx][ty]=t;
                    q.push(P(tx,ty));
                }
            }
        }
    }
    return -1;
}
bool is_strike(int x,int y,int t){
    vector<int>::iterator it;
    sort((strike[x][y]).begin(),(strike[x][y]).end());
    for(int i=0;i<(strike[x][y]).size();i++){
        if(strike[x][y][i]<=t) return 1;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值