Oulipo[字符串哈希]

题目

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

思路

题目的意思就是给定一个子字符串和一个长字符串,要求求出在长字符串中寻找子字符串出现的次数。
通过将字符串转化为一个数字既可方便的判断出两个字符串是否相等,这就是哈希的方法。

代码

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

typedef unsigned long long ull;

const int N = 1e6+10;
char s1[int(1e4+10)], s2[N];
ull power[N]; //预处理
ull H[N]; //长字符串的哈希数组
ull s, b = 27, h = 1<<31; 

int main(void)
{
    power[0] = 1;
    for(int i = 1; i < N; ++i) {
        power[i] = power[i-1]*b;
    }
    int T, n, m, ans;
    scanf("%d", &T);
    while(T--) {
        scanf("%s%s", s1+1, s2+1);
        n = strlen(s1+1); m = strlen(s2+1);
        H[0] = 0;
        for(int i = 1; i <= m; ++i) { //处理长字符串的哈希值
            H[i] = (H[i-1]*b + (ull)(s2[i]-'A'))%h;
        }
        s = 0;
        for(int i = 1; i <= n; ++i) { //算出子字符串的哈希值
            s = (s*b+(ull)(s1[i]-'A'))%h;
        }
        ans = 0;
        for(int i = 0; i <= m-n; ++i) { //依次对哈希值进行比较
            if(s == H[i+n]-H[i]*power[n]) // H数组运用了前缀和的思想,可以在常数时间内算出字符串的哈希值
                ++ans;
        }
        printf("%d\n", ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值