关于简单的字符串Hash

字符串Hash(KMP)属于哈希算法的一种,主要用于解决字符串匹配问题,就以前碰到这类题目我一定会去直接暴力模拟,但是这样就会超时,用字符串Hash就可以很好的解决这一种问题,他是把一段字符串转化成一种具体的数值,我们成为哈希值,通过匹配数值来判断字符串是否匹配,配上一道例题直观解决一下,这是一道我觉得很典型的例题,就可以当作KMP算法的模板

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

输入

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

输出

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

样例输入

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
样例输出

1
3
0
 


#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include<algorithm>
#include<stdio.h>
#define N 10000+5
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
int a[1005];
int b[1005];
int mp[105][105];
int vis[105];
int d[105];
int lowcost[105];
int n, m;
int nex[1000005];
char s1[1000005], s2[1000005];
void getnex()//获取next数组
{
	int len2 = strlen(s2);
	nex[0] = { -1 };
	int k = -1;
	int j = 0;
	while (j < len2 )
	{
		if (k == -1 || s2[j] == s2[k])
		{
			++k;
			++j;
			nex[j] = k;//最长前缀后缀公共元素
		}
		else
		{
			k = nex[k];
		}
	}
}
int kmp()//字符串匹配
{
	int i = 0, j = 0;
	int len1 = strlen(s1);
	int len2 = strlen(s2);
	int ans = 0;
	while (i < len1)
	{
		
		if (j == -1 || s1[i] == s2[j])
		{
			
			i++;
			j++;
			if (j == len2 )//找到一次子串
				ans++;
		}
		else
		{
			j = nex[j];//子串向右退
		}
	}
	return ans;
}
int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%s%s", s2,s1);		
		getnex();
		printf("%d\n", kmp());

	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值