[SDUT](2117)数据结构实验之链表二:逆序建立链表 ---链式存储(线性表)

数据结构实验之链表二:逆序建立链表

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
Input
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
Output
依次输出单链表所存放的数据。
Example Input
10
11 3 5 27 9 12 43 16 84 22 
Example Output
22 84 16 43 12 9 27 5 3 11 
Hint
不能使用数组!
AC代码:
#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef struct Node
{
    int data;
    struct Node *next;
}node;
void creatLinklist(node * &L,int n)
{
    node *s;
    L = (node *)malloc(sizeof(node));
    L->next = NULL;
    int d;
    for(int i=0;i<n;i++)//头插法
    {
        scanf("%d",&d);
        s = (node *)malloc(sizeof(node));
        s->data = d;
        s->next = L->next;
        L->next = s;
    }
}
void print(node *L)
{
    node *p = L->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p = p->next;
    }
}
int main()
{
    int n;
    node *L;
    scanf("%d",&n);
    creatLinklist(L,n);
    print(L);
    return 0;
}


转载于:https://www.cnblogs.com/WangMeow/p/7535935.html

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值