[HDU](2141)Can you find it? ---二分查找(查找)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 31815    Accepted Submission(s): 7936


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
 
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
 
  
Case 1: NO YES NO
 

解题新知: 
①题意:
第一行给三个数l,n,m表示三个数组(A,B,C)的中元素的个数,下面三行一次是这三个数组的元素、
第四行给你一个数值t,表示要t次S。比如S=1,那么问这三个数组中是否存在Ai,Bj,Ck,使得Ai+Bj+Ck=1
若存在,那么输出"YES",否则输出"NO"。
②思路:如果使用枚举那么复杂度为O(n^3)一定会超时,那么换一种思路,我们可以找任意两个数组,让他们构成一个新数组AB[],即数组A和数组B的每一项互相组合相加,那么AB[l*n],然后我么可以用二分查找的思想,tmp=S-c[i],我们就可以在AB[I*n]中查找tmp,这样一转化,时间就得到了优化~


AC代码:

#include<iostream>
#include<cstring>
#include<algorithm>
long long ab[250005];
using namespace std;
int bSearch(int first,int last,int key)
{
    int mid;
    while(first<=last)
    {
        mid=(first+last)/2;
        if(ab[mid]==key)
            return 1;
        else if(ab[mid]<key)
        {
            first=mid+1;
        }
        else
            last=mid-1;
    }
    return 0;
}
int main()
{
    int l,n,m;
    int ccount=1;
    while(cin>>l>>n>>m)
    {
        int a[505];
        int b[505];
        int c[505];
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        memset(ab,0,sizeof(ab));
        for(int i=0;i<l;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
            cin>>b[i];
        for(int i=0;i<m;i++)
            cin>>c[i];
        int sum=0;
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<n;j++)
                ab[sum++]=a[i]+b[j];
        }
        sort(ab,ab+sum);
        int t;
        cin>>t;
        cout<<"Case "<<ccount++<<":"<<endl;
        while(t--)
        {
            int fn;
            cin>>fn;
            int tmp;
            int i;
            for(i=0;i<m;i++)
            {
                tmp=fn-c[i];
                if(bSearch(0,sum-1,tmp))
                {
                    cout<<"YES"<<endl;
                    break;
                }
            }
            if(i==m)
                cout<<"NO"<<endl;
        }
    }
    return 0;
}



转载于:https://www.cnblogs.com/WangMeow/p/7535960.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值