HDU——Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
Input
    There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
Output
    For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
Sample Input
    3 3 3
    1 2 3
    1 2 3
    1 2 3
    3
    1
    4
    10
Sample Output
    Case 1:
    NO
    YES
    NO
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;

long a[501];
long b[501];
long c[501];
long long book[505*505];
int l,n,m;
int x,s;
int ss=0;


int find(int x,int b)
{
        int left=0,right=b;
        while(left<=right)
        {
            int middle=(left+right)/2;
            if(book[middle]==x)
            {
                //cout<<"book:"<<book[middle]<<endl;
                return 1;
            }
            else if(book[middle]<x)
                left=middle+1;
            else if(book[middle]>x)
                right=middle-1;
        }
    return 0;
}

int main()
{

    while(cin>>l>>n>>m)
    {
        int k=0;
        for(int i=0;i<l;i++)
        {
            cin>>a[i];
        }
        for(int i=0;i<n;i++)
        {
            cin>>b[i];
        }
        for(int i=0;i<m;i++)
        {
            cin>>c[i];
        }
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<n;j++)
            {
                book[k]=a[i]+b[j];
                k++;
            }
        }
        sort(book,book+k);
        k=unique(book,book+k)-book;
        sort(c,c+m);
        ss++;
        cout<<"Case "<<ss<<":"<<endl;
        cin>>s;
        while(s--)
        {
            cin>>x;
            int i;
            if(x<(c[0]+book[0])||x>(c[m-1]+book[k-1]))
                cout<<"NO"<<endl;
            else
            {
                for(i=0;i<m;i++)
                {
                    int xx=x-c[i];
                    if(find(xx,k-1)==1)
                    {
                        cout<<"YES"<<endl;
                        break;
                    }
                }
                if(i==m)
                    cout<<"NO"<<endl;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值