LightOJ - 1067 lucas定理 模板

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input
Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output
For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input
3

4 2

5 0

6 4

Sample Output
Case 1: 6

Case 2: 1

Case 3: 15

题意:求C(n,m)%p;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
using namespace std;
#define ll long long
const int Max = 1e6;
#define MOD 1000003
ll fac[Max];

void init(ll Max)
{
    fac[0] = 1;
    for(int i = 1; i <= Max; i++)
        fac[i] = fac[i-1] * i % MOD;
    return;
}


ll _pow(ll x, ll y, ll p)
{
    ll res = 1,tmp = x % p;
    while(y)
    {
        if(y & 1)
            res = res * tmp % p;
        tmp = tmp * tmp % p;
        y >>= 1;
    }
    return res;
}


ll C(ll n, ll m, ll p)
{
    if(m > n)
        return 0;
    return fac[n] * _pow(fac[m] * fac[n-m], p-2, p) % p;
}

ll lucas(ll n, ll m, ll p)
{
    if(m == 0)
        return 1;
    return (C(n%p, m%p, p)*lucas(n/p, m/p, p))%p;
}

int main()
{
    int t;
    cin >> t;
    int k = 0;
    init(Max);
    while(t--)
    {
        k++;
        int n,m;
        cin >> n >> m;
        cout << "Case " << k << ": " << lucas(n, m, MOD) << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值