LightOJ1067 Combinations Lucas定理裸题

Description
Given n different objects, you want to take k of them. How many ways to can do it?
For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.
Take 1, 2
Take 1, 3
Take 1, 4
Take 2, 3
Take 2, 4
Take 3, 4
Input
Input starts with an integer T (≤ 2000), denoting the number of test cases.
Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).
Output
For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.
Sample Input
3
4 2
5 0
6 4
Sample Output
Case 1: 6
Case 2: 1
Case 3: 15

模板题。

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;
#define maxn 1000005
#define mod 1000003
LL f[maxn];
void init(LL p)
{
    LL i;
    f[0]=1;
    for(i=1;i<=p;i++){
        f[i]=f[i-1]*i%p;
    }
}
LL powmod(LL a,LL b,LL p) {
    LL res=1;
    while(b!=0){
        if(b&1) res=(res*a)%p;
        a=(a*a)%p;
        b>>=1;
    }
    return
     res;
}

LL Lucas(LL n,LL m,LL p)
{
    LL ans=1;
    while(n&&m){
        LL nn=n%p,mm=m%p;
        if(nn<mm) return 0;
        ans=ans*f[nn]*powmod(f[mm]*f[nn-mm]%p,p-2,p)%p;
        n/=p;
        m/=p;
    }
    return ans;
}

int main() {
    LL a,b;
    int t;
    init(mod);
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        scanf("%lld%lld",&a,&b);
        printf("Case %d: %lld\n",i,Lucas(a,b,mod));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值