poj-3278 catch the cow

1 篇文章 0 订阅
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 107277 Accepted: 33541

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
#define maxn 100010
int n, k;
int visit[maxn];      //数组大于1000必须放在main外面,否则很容易超!!!
struct node
{
	int x;
	int step;
	node(int x, int step) :x(x), step(step) {}
};
int main()
{
	cin >> n >> k;
	memset(visit, 0, sizeof(visit));
	queue<node>q;
	q.push(node(n,0));
	visit[n] = 1;
	while (!q.empty())
	{
		node p = q.front();
		if (p.x == k)
		{
			cout << p.step << endl;
			return 0;
		}
		else
		{
			if (p.x >=0 && !visit[p.x-1])
			{
				q.push(node(p.x-1,p.step+1));   //p.x和p.step
				visit[p.x-1] = 1;
			}
			if (p.x < maxn && !visit[p.x+1])
			{
				q.push(node(p.x + 1, p.step + 1));
				visit[p.x+1] = 1;
			}
			if (p.x * 2 <= maxn && !visit[p.x * 2])
			{
				q.push(node(p.x * 2, p.step + 1));
				visit[p.x * 2] = 1;
			}
			q.pop();
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值