poj Catch That Cow (Bfs)

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 25   Accepted Submission(s) : 9
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers:  N and  K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
 

Source
PKU

入门题,注意边界和判重

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

struct Node{
    int x,c;
}pos[200005];
queue <Node> q;
int n,k;
bool vist[200005];

int Bfs(){
    int p,countn;

    while(!q.empty()){
        p = q.front().x;
        countn = q.front().c;
        q.pop();
        if(p == k)
            return countn;
        if(!vist[p - 1] && p > 0){
            vist[p - 1] = 1;
            pos[p - 1].c = countn + 1;
            pos[p - 1].x = p - 1;
            q.push(pos[p - 1]);
        }
        if(p < k){
            if(!vist[p + 1]){
                vist[p + 1] = 1;
                pos[p + 1].c = countn + 1;
                pos[p + 1].x = p + 1;
                q.push(pos[p + 1]);
            }
            if(!vist[p * 2]){
                vist[p * 2] = 1;
                pos[p * 2].c = countn + 1;
                pos[p * 2].x = p * 2;
                q.push(pos[p * 2]);
            }
        }
    }
}

int main(){
    int i,j;

    while(scanf("%d%d",&n,&k) != EOF){
        memset(vist,0,sizeof(vist));
        memset(pos,0,sizeof(pos));
        while(!q.empty())//用到队列要记得初始化
            q.pop();
        vist[n] = 1;
        pos[n].x = n;
        pos[n].c = 0;
        q.push(pos[n]);
        printf("%d\n",Bfs());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值