Poj 3278-Catch That Cow(裸一维BFS)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 46671 Accepted: 14656

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a pointK (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

简单的BFS,只需要一点小小的剪枝,。。不然各种RE
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;
int n,k;
bool vis[4000010];
typedef struct node
{
	int x;
	int step;
};
void bfs()
{
	node t,f;
	t.x=n;t.step=0;
	queue <node> Q;
	vis[t.x]=1;
	Q.push(t);

	while(!Q.empty())
	{
		t=Q.front();Q.pop();
		if(t.x==k)
		{
			printf("%d\n",t.step);
			return ;
		}
	    if(t.x-1>=0&&!vis[t.x-1]&&t.x-1<=200000)//如果t.x==0 此时在减一会RE
		{
			f.x=t.x-1;
			f.step=t.step+1;
			if(f.x==k)
			{
				printf("%d\n",f.step);
				return ;
			}
			vis[t.x-1]=1;
			Q.push(f);
		}
		if(!vis[t.x+1]&&t.x+1>=0&&t.x+1<=200000)
		{
			f.x=t.x+1;
			f.step=t.step+1;
			if(f.x==k)
			{
				printf("%d\n",f.step);
				return ;
			}
			vis[t.x+1]=1;
			Q.push(f);
		}
		if(!vis[t.x*2]&&t.x*2>=0&&t.x*2<=200000)//*2容易RE 所以直接让它不超过题目所给范围
		{
			f.x=t.x*2;
			f.step=t.step+1;
			if(f.x==k)
			{
				printf("%d\n",f.step);
				return ;
			}
			vis[t.x*2]=1;
			Q.push(f);
		}
	}
}
int main()
{
    scanf("%d%d",&n,&k);
    memset(vis,0,sizeof(vis));
    bfs();
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值