先发个不错的链接
http://www.cppblog.com/Onway/archive/2010/08/09/122695.html
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
OutputFor each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0Sample Output
3 4 6
题意:n个课程 时间为m天 a[i][j]表示第i个课程学习j天的收益
分组背包:每种课程只能选一次,可以吧每组看成是一个01背包
#include<iostream>
#include<cstring>
using namespace std;
int a[101][101];
int dp[101]; //dp[i]为前i天的最大收益
int main()
{
int n,m;
while(cin>>n>>m&&n*m)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
cin>>a[i][j];
}
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
for(int j=m;j>=1;j--)
{
for(int k=1;k<=j;k++) //k<=j 确保能放进去 刚开始写的k<=m 一直WA
{
dp[j]=max(dp[j],dp[j-k]+a[i][k]); //a[i][k]不要写成a[i][j]
}
}
}
cout<<dp[m]<<endl;
}
}