PAT Advanced 1007 Maximum Subsequence Sum

Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

求和最大的连续子序列及其起点终点。将从第一个数到第i个数的和保存至dp[i]中,用dp[right]-dp[left-1]得到第left个数到第right个数的和,枚举求解。
#include <bits/stdc++.h>

using namespace std;

int main()
{
    long long dp[10010];
    int K;
    cin>>K;
    dp[0]=0;
    long long sum=0,tmp=0;
    for(int i=1;i<=K;i++)
    {
        cin>>tmp;
        sum+=tmp;
        dp[i]=sum;
    }
    long long mans=-1;
    int lft=1,rht=K;
    for(int i=1;i<=K;i++)
    {
        for(int j=i;j<=K;j++)
        {
            long long tans=dp[j]-dp[i-1];
            if(tans>=0)
            {
                if(tans>mans)
                {
                    mans=tans;
                    lft=i,rht=j;
                }

            }
        }
    }
    cout<<(mans>=0?mans:0)<<' '<<dp[lft]-dp[lft-1]<<' '<<dp[rht]-dp[rht-1]<<endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/zest3k/p/11450499.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值